vtiger supports PHP 5.2!

Few more days to go make it in realisation. A week after a tight scheduled release of vtiger CRM 5.0.3, we are back to work, had enough time to relax, still we have our developers who will be on compensatory off in the coming week too. Minnie and I have planned to take up tasks such as PHP 5.2.x support, UTF-8 support across the product including the database and starting mysql as service in our exe version. I hope many of our developers and users would have faced lot of issues while installing vtiger on php 5.2.x and with character set, i’hve collected issues from forums apart from this if any of you, have come across with new issues, do post your issues / suggestions here, this will be helpful in achieving the task quicker. Iam rightnow testing vtiger 5.0.3 with PHP 5.2.1, found few issues after fixing i was able to install sucessfully. Expecting issues during the walkthrough. Awaiting for your feedback. Have a great weekend!
Sort by:   newest | oldest | most voted
Guest
jcarlosa
12 years 3 months ago

Dear philip,

Tanks lot for the magnificent work in the 5.0.3.

Extend our gratefulness to all team.

We are initiating evaluation of vtiger and have 5.2.1 PHP in GENTOO and UTF-8 in MySql.

We made some tests with SugarCRM but we are not very happy.

By the way you he could cite the main differences of contruções with vTigerCRM and SugarCRM?

Tanks.

Guest
Lukas
12 years 3 months ago

BEST OF THE YEAR IDEA! is UTF-8 support across the product including the database.

We are looking forward for it couple years 🙂

Guest
chrispi
12 years 3 months ago

Hey, that sounds REALLY good. If UTF is being fully supported, that will solve one of the few issues that still bothers my company with the current release.
Also 5.2 will be much appreciated 🙂 (and I’m quite sure that his applies for many others in the community as well)

Guest
Guy
12 years 3 months ago

Is PDF export will support utf-8 too?

Guest
Gary Pigott
12 years 3 months ago

Is the PHP 5.2 compatability going to be a point release (5.0.4/5.0.3a), or are we going to be going to have to mess about with CVS or patches? Frankly I was stunned when the PHP 5.2 fix was not considered for the 5.0.3 release seeing as a) it’s a known issue affecting the majority of new deployments, and b) there are 3rd party workarounds in the forum, so it was never going to be a huge job.

Guest
Cody Heit
12 years 3 months ago

Yes I would like to see a patch so that vtiger works for:

PHP: 5.2.2

and

MySQL: 4.1.22

Guest
Mr. Jons
12 years 3 months ago

Yes – please support php 5.2.

vt 5.0.2 (patched for php 5.2) is running and I do not like to change the running system until vt 5.0.3 will support php 5.2.

Regards
Jons

Guest
Mike Mure
12 years 3 months ago

How long will it take you to offer a new vtiger for php 5.2.

vtiger 5.02/php 5.2 ist working quite well and we do not want to run into new problems.

Guest
Cody
12 years 3 months ago

Thanks sounds great

Guest
Mason
12 years 3 months ago

Supporting php5.2 … sounds great. I am looking forward to the patch!

Guest
Pierre-André
12 years 3 months ago

php 5.2 support is a good and important step for vtiger.
thanks for your work.

Guest
Hans
12 years 3 months ago

PHP 5.2.2 and UTF-8 -> my 2 problems!
I’m happy for a patch in the next time.
Thanks for your work!

Guest
Lukas
12 years 3 months ago

UTF-8

Guest
Norbert
12 years 3 months ago

PLEASE make sure to provide a UTF-8 patch ASAP – it seems that this is a killer problem for the Outlook Sync, and not just for us (have a look at the forums)…

Guest
Hans
12 years 3 months ago

Thank you, Philip!

I have tested with PHP 5.2.1 -> 0 problems
That’s very good!

Guest
Rok
12 years 3 months ago

Thank , Philip!
I tested with PHP 5.2.1 its o.k.
I add ErrorHandler.php and in “config.inc.php” below the comments before include(‘vtigerversion.php’)-
require_once(‘ErrorHandler.php’);

Guest
Hans
12 years 3 months ago

I have make a new installation with php5.2.1:

1. upload 5.0.3
2. upload patch php5.2
3. start /install.php
4. In the last step “Internal Server Error”
(the database have records without data)

What can I do?

Guest
Hans
12 years 3 months ago

Sorry: new installation with strong (not strike!)

Install with php4 and later switch to php5.2.1 is o.k.

except:
A running 5.0.3 with php5.2.1 give by webmail a white page (I can see menu only).

Guest
Cody
12 years 3 months ago

Does the patch just work for PHP 5.2 or will it also allow vtiger 5.0.3 to run under PHP 4?

Guest
Jahn
12 years 3 months ago

I am running vtiger 5.0.2 and php 5.2. Do I only have to install the patch or the whole vtiger 5.0.3?

Guest
Ken
12 years 3 months ago

Hi Philip,

This didn’t seem to cure my problem – when I add a new contact it does not save.

Any ideas?

Ken

Guest
Ben
12 years 3 months ago

Same thing Ken, so you’re not alone.

Guest
Ben
12 years 3 months ago

Thanks Philip,

I ended up doing yet another reinstall and managed to get it working this time. I had to make an ErrorHandler.php file and edit config.template.php though to get it working right this time.

Webmail still loads a blank page though.

Guest
Dieu
12 years 3 months ago

I did install patch, and I have this error at step 5:
Can’t create table ‘./vtigercrm503/#sql-726b_ba.frm’ (errno: 121)Error: Tables partially created. Table creation failed.

at Mysql 5.0.37 I got this at log (this is just a sample, but there is a lot):

070618 16:30:52 InnoDB: Error: in ALTER TABLE `vtigercrm503/vtiger_entityname`
InnoDB: has or is referenced in foreign key constraints
InnoDB: which are not compatible with the new table definition.
070618 16:30:52 InnoDB: Error: table `vtigercrm503/vtiger_entityname` does not exist in the InnoDB internal
InnoDB: data dictionary though MySQL is trying to drop it.
InnoDB: Have you copied the .frm file of the table to the
InnoDB: MySQL database directory from another database?
InnoDB: You can look for further help from
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/innodb-troubleshooting.html

As importan data, at Mysql DB, there are many tables.

Guest
Jahn
12 years 3 months ago

No answer? I try it again:

I am running vtiger 5.0.2 and php 5.2. Do I only have to install the patch or the whole vtiger 5.0.3?

Guest
Ben
12 years 3 months ago

Jahn,

I really woudn’t touch 5.03 with php 5.2 until they get their act together and release a proper patch. WHen they do, you’ll install the upgrade to 5.02 then the patch.

Guest
richie
12 years 3 months ago

We are doing the testings and are finding out some issues here and there with the PHP5.2 support. Once we are through with them, we will be able to announce it to the community.

Then, I guess, the world will be a happier place to live in ;-). This is good impetus for you folks to buy the support packages too, right?

Guest
Mark
12 years 3 months ago

I have PHP 5.2 installed on a Debian box with Vtiger 5.0.3. Imap mail module is loaded with php but I still get the blank mail screen when trying to view my inbox. ideas of what to check?

Thanks

Guest
Jahn
12 years 3 months ago

Hello Philip

Need to upgrade your 5.0.2 to 5.0.3 by applying the patch3 and then apply the php 5.2 patch.

looking at http://www.vtiger.com/index.php?option=com_content&task=view&id=30&Itemid=57 I only find “v5.0 Patch 3” but no “php 5.2 patch”. Where do I find it?

Guest
Alex
12 years 3 months ago

@Guy

On this topic you will find a solution for UTF-8 in reports.

[link removed]
regards

alex

Guest
Lukas
12 years 3 months ago

This is new forum ? 🙂

wpDiscuz
Holiday season, Christmas, Thanksgiving, Out-of-office, email templates

10 Outstanding Out of Office Email Templates You Can Use in 2019

It’s that time of the year again and you are all set to kick back and enjoy the holiday season. The season to be jolly ...
Vtiger_customer_loyalty

Promoting real loyalty goes through customer engagement

About the author Denis Pombriant is CRM marketplace analyst and consultant. Founder and managing principal, Beagle Research Group, LLC. He is the ...
Sales Meeting, Sales Managers, Sales Representative

How to Run an Effective Sales Meeting

The sales team is the quarterback of your company. Your entire organization is structured such that the sales team gets an advantage on the field ...
Valuable sales intro

3 customer preferences that businesses need to know to grow

Are you looking for an advantage? A way to differentiate your business from your competitors? A sure-fire way to be memorable with customers and to ...
Top Features, CRM, Vtiger, Sales managers

Top CRM Features Sales Managers Need in 2019

Gone are the days when sales managers had to plough through a barrage of spreadsheets to keep track of customers and their purchases. With a ...
Vtiger_social_selling

7 proven tips (and one nifty tool) to improve your LinkedIn social selling effort

If you’re selling in the digital age, then you’ve likely come across the term social selling. Sales professionals are increasingly turning towards social channels such ...
P Ramesh Chander, Rixyncs, Three pillars, customer relationships

Insights from ‘Three Pillars of Customer Relationship’

There is no doubt in anyone’s mind that the customer is the most important aspect of any business. In layman’s terms, without a customer, you ...
GMQ

Vtiger recognized as a Niche player in Gartner 2019 Magic Quadrant for Sales Force Automation

Gartner has released its June 2019 report, “Magic Quadrant for Sales Force Automation” and we are happy to announce that Vtiger has been recognized amongst ...
Getting_ready_for_AI

How can you be prepared to ride the AI wave

Artificial intelligence(AI) is here to stay and it will transform the way you sell. From managing online conversations on websites to analysing massive amount of ...
AI_replace_salesrep

Will Artificial Intelligence replace sales reps

Artificial intelligence(AI) is here to stay and it will transform the way you sell. From managing online conversations on websites to analysing massive amount of ...
loading
Copyright 2018 Vtiger | Privacy Policy